Re: [PARPORT] Re: [PARPORT] Hello, Im new in this list

From: jens@nietzsche.glueckauf.verb.tu-clausthal.de
Date: Wed Nov 01 2000 - 23:38:25 EST

  • Next message: Tim Waugh: "[PARPORT] Re: [PARPORT] Re: [PARPORT] Hello, Im new in this list"

    On Wed, 1 Nov 2000, Tim Waugh wrote:

    Hi Tim, thank you four your fast answer.

    > <URL:http://people.redhat.com/twaugh/parport/html/>
    >
    > (Hmm, must update that...)

    I already visited this URL and find very interesting documents.
    Meanwhile I got the patch for 2.2.x kernels for the ppdev support and
    installed it successfully on Linux 2.2.14 and 2.2.16. ( I used the
    patch-2.2.15pre.14-ppdev1). Also compiling was successful.

    After
    insmod parport
    insmod parport_pc io=0x378 irq=9 (I also tried 11 and 12)
    insmod ppdev

    I tried to run my little program, that should only reset all data lines of
    the parallel port. But instead of a result nothing happens. The
    ioctl() function call returns with success after PPWDATA.

    In the kernel messages I found the following:

    ppdev: user-space parallel port driver
    ppdev0: registered pardevice
    ppdev0: negotiated back to compatibility mode because user-space forgot
    ppdev0: released pardevice because user-space forgot
    ppdev0: unregistered pardevice

    What am I doing wrong? Everything seems to work fine.

    Greetings, Jens

                                   ICQ #33135877
                ()___() http://home.tu-clausthal.de/~ifjkoe
                 (o o) jens.koehler@tu-clausthal.de
    ---------oOO--(.)--Ooo-------------------------------------------------------

    -- To unsubscribe, send mail to: linux-parport-request@torque.net --
    -- with the single word "unsubscribe" in the body of the message. --



    This archive was generated by hypermail 2b29 : Wed Nov 01 2000 - 22:48:19 EST