Re: [PARPORT] NetMos parallel port lost after unplugging of another PCI card

From: Norbert Preining (preining@logic.at)
Date: Mon Aug 04 2003 - 17:18:51 EDT

  • Next message: Robert Heller: "Re: [PARPORT] NetMos parallel port lost after unplugging of another PCI card"

    Hello friends!

    Maybe my previous email was lost, but I am still searching for any
    solution to my problem. No changes till now, with none of the new
    kernels I tried:

    On Mon, 21 Jul 2003, Norbert Preining wrote:
    > I have the following problem:
    >
    > I have:
    > 00:0c.0 Serial controller: NetMos Technology 222N-2 I/O Card (2S+1P) (rev 01) (prog-if 02 [16550])
    > Subsystem: LSI Logic / Symbios Logic: Unknown device 0012
    > Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
    > Status: Cap- 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
    > Interrupt: pin A routed to IRQ 12
    > Region 0: I/O ports at b800 [size=8]
    > Region 1: I/O ports at bc00 [size=8]
    > Region 2: I/O ports at c000 [size=8]
    > Region 3: I/O ports at c400 [size=8]
    > Region 4: I/O ports at c800 [size=8]
    > Region 5: I/O ports at cc00 [size=16]
    >
    > I have:
    > options parport_pc irq=7,none dma=3,none io=0x0378,0xc400 io_hi=0x0778,0
    > options lp parport=1
    >
    > It was all working.
    >
    > The serial port where here:
    > /dev/ttyS2, UART: 16550A, Port: 0xbc00, IRQ: 5
    > /dev/ttyS3, UART: 16550A, Port: 0xc000, IRQ: 5
    >
    >
    > Then I took out a networking card and the IRQ of the NetMos card changed
    > to 12 (see above, before it was 5).
    >
    > Now the serial ports are:
    > /dev/ttyS2, UART: 16550A, Port: 0xbc00, IRQ: 12
    > /dev/ttyS3, UART: 16550A, Port: 0xc000, IRQ: 12
    > and working. But when I load the parport(_pc) modules with the above
    > parameters I get this in the syslog:
    >
    > parport0: PC-style at 0x378 (0x778), irq 7, dma 3 [PCSPP,TRISTATE,COMPAT,ECP,DMA]
    > parport 0xc400 (WARNING): CTR: wrote 0x0c, read 0x0d
    > parport 0xc400 (WARNING): DATA: wrote 0xaa, read 0x00
    > parport 0xc400: You gave this address, but there is probably no parallel port there!
    > parport1: PC-style at 0xc400 [PCSPP,TRISTATE,EPP]
    >
    > Can you tell me where my parport is lost?
    >
    > Thanks a lot for any hint and tips!
    >
    > I am using debian/sid, linux-2.4.22-pre7.

    Best wishes

    Norbert

    -------------------------------------------------------------------------------
    Norbert Preining <preining AT logic DOT at> Technische Universitšt Wien
    gpg DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
    -------------------------------------------------------------------------------
    BEALINGS
    The unsavoury parts of a moat which a knight has to pour out of his
    armour after being the victim of an araglin (q.v.). In medieval
    Flanders, soup made from bealins was a very slightly sought-after
    delicacy.
                            --- Douglas Adams, The Meaning of Liff

    -- To unsubscribe, send mail to: linux-parport-request@torque.net --
    -- with the single word "unsubscribe" in the body of the message. --



    This archive was generated by hypermail 2b29 : Mon Aug 04 2003 - 17:28:20 EDT