Andrea Arcangeli (email@example.com)
Mon, 31 Aug 1998 15:02:33 +0200 (CEST)
On Mon, 31 Aug 1998, Philip Blundell wrote:
>core altogether. We could probably lose the examine_irq() method along the
>way also, since as has been pointed out it doesn't have very well defined
>semantics, and it shouldn't be necessary anyway.
Very well so I can now define the new well defined semantic ;-).
>Maybe it would be better to let Joerg come up with the patch since he seems to
>have a clearer idea of what needs doing.
I think that parport lowlevel developers will feel better without having
to play with spinlocks and other parport scheduling things and I' d like
to not produce code duplication. The way I implemented the call for
parport_examine_irq() (that is defined as return 0 here) got completly
optimized out from the asm if PARPORT..OTHERS is not set.
-- To unsubscribe, send mail to: firstname.lastname@example.org --
-- with the single word "unsubscribe" in the body of the message. --
This archive was generated by hypermail 2.0b3 on Wed 30 Dec 1998 - 10:18:11 EST